Forums

angle-left Back

How to disable border by default?

DA
David Atkins, modified 11 Years ago.

How to disable border by default?

New Member Posts: 23 Join Date: 1/29/07 Recent Posts
When I add a portlet to a page, the border displays by default. I have to click configure and then uncheck the box for Show Borders to make it go away. Is there a setting, at the application or portlet level, to make the borders disabled?
Alaaeldin El-Nattar, modified 11 Years ago.

RE: How to disable border by default?

New Member Posts: 15 Join Date: 3/9/07 Recent Posts
Hi,

You can change that behavior by setting the portlet preferences in portlet.xml.

<portlet-preferences>
  <preference>
    <name>portlet-setup-show-borders</name>
    <value>false</value>
  </preference>
</portlet-preferences>


You have to do it for each portlet you want to disable borders by default for.

Hope this helps,

-Aladdin
AG
André Gervásio, modified 9 Years ago.

RE: How to disable border by default?

New Member Posts: 2 Join Date: 7/30/08 Recent Posts
Fine! Works!


Alaaeldin El-Nattar:
Hi,

You can change that behavior by setting the portlet preferences in portlet.xml.

<portlet-preferences>
  <preference>
    <name>portlet-setup-show-borders</name>
    <value>false</value>
  </preference>
</portlet-preferences>


You have to do it for each portlet you want to disable borders by default for.

Hope this helps,

-Aladdin
delang j, modified 8 Years ago.

RE: How to disable border by default?

Expert Posts: 252 Join Date: 7/13/08 Recent Posts
hi Alaaeldin,

i did test my local LR 511 and LR 523 but it ain't working. am i miss something or did some mistake?
here my code
    <portlet>
        <portlet-name>56</portlet-name>
        <display-name>Journal Content</display-name>
        <portlet-class>com.liferay.portlet.StrutsPortlet</portlet-class>
        <init-param>
            <name>view-action</name>
            <value>/journal_content/view</value>
        </init-param>
        <expiration-cache>0</expiration-cache>
        <supports>
            <mime-type>text/html</mime-type>
        </supports>
        <supports>
            <mime-type>application/vnd.wap.xhtml+xml</mime-type>
        </supports>
        <resource-bundle>com.liferay.portlet.StrutsResourceBundle</resource-bundle>
        <portlet-preferences>
          <preference>
            <name>portlet-setup-show-borders</name>
            <value>false</value>
          </preference>
        </portlet-preferences>
        <security-role-ref>
            <role-name>guest</role-name>
        </security-role-ref>
        <security-role-ref>
            <role-name>power-user</role-name>
        </security-role-ref>
        <security-role-ref>
            <role-name>user</role-name>
        </security-role-ref>
    </portlet>


thanks
Renee Talabucon, modified 8 Years ago.

RE: How to disable border by default?

Junior Member Posts: 31 Join Date: 3/28/10 Recent Posts
Hi~

This code doesn't work for me either. :/


<portlet-preferences>
<preference>
<name>portlet-setup-show-borders</name>
<value>false</value>
</preference>
</portlet-preferences>   


Any other options?

Actually, I want to try setting the Web Content Display portlet to no borders by default because whenever I uncheck "Show borders" in Look and Feel -> Portlet Configuration , I get a " Internal Server Error - An error occurred while accessing the requested resource. " status. And that I don't get at all.

Thanks for all the help in advance. emoticon


Edit: I'm using glassfish v2, liferay 6.0.3 GA1
Milan Jaroš, modified 9 Years ago.

RE: How to disable border by default?

Expert Posts: 269 Join Date: 8/18/08 Recent Posts
Hello,
there is solution on Theme level... So, you can modify key portlet-setup-show-borders-default in liferay-look-and-feel.xml.

It must be placed in settings (see part of file):


<look-and-feel>
    <theme>
        <settings>
            <setting key="portlet-setup-show-borders-default" value="true"></setting>
        </settings>
    </theme>
</look-and-feel>
Kyrre Myrbostad, modified 9 Years ago.

RE: How to disable border by default?

Junior Member Posts: 37 Join Date: 1/21/09 Recent Posts
Hi, I have a similar situation but the solution isn't quite up to it:

If you disable the borders on the portlet, there seems to be a standard "top section" that is presented, with text instead of icons. How do i get rid of this one? This doesn't seem to come from the velocity template. I can ofc adjust the portlet.vm to my taste, but if this replacement text can be manipulated that seems to be a more consistent way of doing it.

What I'm trying to achieve here is a set of fixed portlets where a user can only add content or work inside the portlets - not change the way they look / behave.
Milan Jaroš, modified 9 Years ago.

RE: How to disable border by default?

Expert Posts: 269 Join Date: 8/18/08 Recent Posts
Hello,
you have to understand that you can see this labels because you are "admin" (you have rights). Note, guest or normal User will not see this. If so you have to set roles correctly to get from portal what you want. ;)
Please read some wiki's (something like "Get started" or else).

Here is something about roles in Liferay (if you find more somewhere else post it here).
Florence H, modified 8 Years ago.

RE: How to disable border by default?

Junior Member Posts: 51 Join Date: 11/3/09 Recent Posts
You can add
<use-default-template>false</use-default-template>

in liferay-portlet.xml
But even an admin cannot remove the portlet...
VC
Vijay Chandra, modified 5 Years ago.

RE: How to disable border by default?

New Member Posts: 8 Join Date: 4/4/13 Recent Posts
Hi All,

Recently we migrated from Liferay 6.0 to 6.1 and faced a problem that, portlets which are having view.jsp and edit.jsp , portlet border (title and preference icon) are visible.But for the portlet having only view are not displaying any thing.

Solution i tried till now
i) uncheck show border to that particular portlets but failed,
ii) Added

<portlet-preferences>
<preference>
<name>portletSetupShowBorders</name>
<value>false</value>
</preference>
</portlet-preferences>

in portlet.xml for that particular portlet but failed.

iii) Added theme.portlet.decorate.default=false in portal-ext.properties but failed.

iv) My liferay-look-and-feel.xml is having this code too

<look-and-feel>
<compatibility>
<version>6.1.0+</version>
</compatibility>
<theme id="CRPortal" name="CR Portal Theme">
<settings>
<setting key="portlet-setup-show-borders-default" value="false"></setting>
</settings>
</theme>
</look-and-feel> but its vain.

Please help me if any working solution is there to hide the titles and icon for portlets when logged in as normal user

Thanks
Vijay Chandra Kondamudi
Ahmed bouchriha, modified 5 Years ago.

RE: How to disable border by default?

Junior Member Posts: 55 Join Date: 5/4/12 Recent Posts
Hi Vijay Chandra

i think this post is describing better your problem since you posted here your liferay-look-and-feel.xml code
its wear why it didn't work for you you are using the right setting
<setting key="portlet-setup-show-borders-default" value="false"></setting>
.
try to make your
<setting key="portlet-setup-show-borders-default" value="false"></setting> configurable by replacing

<setting key="portlet-setup-show-borders-default" value="false"></setting>


with
<setting configurable="true" key="portlet-setup-show-borders-default" type="checkbox" value="false"/>

note the configurable="true" and type="checkbox" that will allow you to control the setting from your manage-page

go to your site open manage-page ----> select the root of your page tree ---> look and feel ----> setting you will find :

see attached file .

all you have to do is to uncheck it .
i wish it helps and good luck

for custom themes feel free to visit https://www.themeray.com.